読者です 読者をやめる 読者になる 読者になる

みかづきメモ

学習したことのメモとか、日記とか、備忘録。

OS X El Capitan で therubyracer をいれる

いつもどおり Ruby + Rails 環境整えて、いざ bundle install すると、
therubyracer まわりでエラーが起きたので、メモです。


qiita.com

上の記事によると、 OS バージョンと libv8, therubyracer のバージョンを
それぞれ合わせる必要があるらしいです。
しかしながら、合わせてもエラーが起きていました。

私が解決した方法は、まず、すでにインストールされている libv8 を
一旦アンインストールします。

gem uninstall libv8

その後、 therubyracer を入れます。

gem install therubyracer -v '0.12.1' -- --with-v8-dir

そうすると、自動で libv8 も導入され、無事 therubyracer を導入できました。